Boost logo

Boost :

From: Marcus Lindblom (macke_at_[hidden])
Date: 2008-05-22 09:03:10

John Femiani wrote:
> Marcus wrote:
>> John Femiani wrote:
>>> How about deprecating branch_path and using 'head', and deprecating
>>> 'leaf' in favor of 'tail'? This replaces tree terms with
>>> list terms, since a path is a list.
>> The way I'm used to name lists (from Haskell and others), is
>> that a list of x has a head of type x and a tail of type 'list of x'.
>> Your version would turn that around, which would confuse me.
> Oops, your right. 'back' would be a lot better, given the c++ precedent
> (std::list).

Indeed. back() is excellent.

Still, does it justify breaking backwards compatibility?

>> (We're getting dangerously close to the bike-shed... :)
> Sorry, I just wanted to try and step up to Beman's challenge:
>> If you have a better set of names, why don't you suggest them?

Ah. Well, he should've knwon better. ;-P


Boost list run by bdawes at, gregod at, cpdaniel at, john at