From: David Abrahams (dave_at_[hidden])
Date: 2008-05-30 18:51:24
on Thu May 29 2008, John Femiani <JOHN.FEMIANI-AT-asu.edu> wrote:
>> >>> If possible, at this late stage, the names should be changed.
>> >> Why don't you and Dave come up with a proposed set of names? The
>> >> current names are:
>> >> root_path
>> >> root_name
>> >> root_directory
>> >> relative_path
>> >> leaf
>> >> branch_path
>> >> basename
>> >> extension
>> > I think all these names are fine except "leaf" and "branch_path".
>> > If anyone asked me "What does the function branch_path return?", I
>> > would answer "The parent directory."
>> > So why not call it parent_directory_path?
>> Or just parent_path(). That's an interesting suggestion, thanks!
> I think it is interesting that the wikipedia community distinguishes
> windows filenames from unix filenames, so that on unix systems the
> 'extension' is part of the name but on windows systems it is not.
The latter is "true" in some sense from the user's perspective, or at
least Windows tries to present that illusion. But every programmer
quickly learns that the extension *is* really part of the file's name on
Windows. We're presenting names for programmers, not GUI users.
-- Dave Abrahams BoostPro Computing http://www.boostpro.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk