From: John Femiani (JOHN.FEMIANI_at_[hidden])
Date: 2008-05-29 11:36:19
> >>> If possible, at this late stage, the names should be changed.
> >> Why don't you and Dave come up with a proposed set of names? The
> >> current names are:
> >> root_path
> >> root_name
> >> root_directory
> >> relative_path
> >> leaf
> >> branch_path
> >> basename
> >> extension
> > I think all these names are fine except "leaf" and "branch_path".
> > If anyone asked me "What does the function branch_path return?", I
> > would answer "The parent directory."
> > So why not call it parent_directory_path?
> Or just parent_path(). That's an interesting suggestion, thanks!
I think it is interesting that the wikipedia community distinguishes
windows filenames from unix filenames, so that on unix systems the
'extension' is part of the name but on windows systems it is not.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk