Boost logo

Boost :

From: Ralf W. Grosse-Kunstleve (rwgk_at_[hidden])
Date: 2008-06-02 15:35:14

I'm routinely testing Boost.Python compilation with Intel C++ under Fedora 3
(64-bit). Today I tried Fedora 5, 6, 9, and I'm getting the error below. It
can be reproduced by simply including boost/shared_ptr.hpp. I tried adding
-pthread but it didn't make a difference. Is this a known problem? Is there
a trick to get around it?

P.S.: Intel C++ 9.1 behaves the same way.

boost trunk svn revision 46049

% cat include_boost_shared.cpp
#include <boost/shared_ptr.hpp>

% icpc -V
Intel(R) C++ Compiler for applications running on Intel(R) 64, Version 10.1 Build 20080312 Package ID: l_cc_p_10.1.015
Copyright (C) 1985-2008 Intel Corporation. All rights reserved.

% icpc -I/net/rosie/scratch1/rwgk/hot/boost -c include_boost_shared.cpp
/net/rosie/scratch1/rwgk/hot/boost/boost/detail/spinlock_sync.hpp(36): error: identifier "__sync_lock_test_and_set" is undefined
          int r = __sync_lock_test_and_set( &v_, 1 );

/net/rosie/scratch1/rwgk/hot/boost/boost/detail/spinlock_sync.hpp(50): error: identifier "__sync_lock_release" is undefined
          __sync_lock_release( &v_ );

compilation aborted for include_boost_shared.cpp (code 2)

Boost list run by bdawes at, gregod at, cpdaniel at, john at