Boost logo

Boost :

From: Simonson, Lucanus J (lucanus.j.simonson_at_[hidden])
Date: 2008-06-02 18:12:16

Ralf wrote:
>I'm routinely testing Boost.Python compilation with Intel C++ under
Fedora >3
>(64-bit). Today I tried Fedora 5, 6, 9, and I'm getting the error
below. It
>can be reproduced by simply including boost/shared_ptr.hpp. I tried
>-pthread but it didn't make a difference. Is this a known problem? Is
>a trick to get around it?
>P.S.: Intel C++ 9.1 behaves the same way.


I tried to reproduce your problem and was unable to:

> cat test3.cpp
#include <boost/shared_ptr.hpp>
int main() { return 0;} //so that I don't get main undefined error
> /usr/intel/pkgs/icc/10.0.026/bin/icc -I ~/30days/boost-trunk test3.cpp
> sysname -cpu

It also works with icc 9.0

> /usr/intel/pkgs/icc/9.0.030/bin/icc -I ~/30days/boost-trunk test3.cpp

Note: no compiler errors.

That was from the boost trunk from when I checked it out on May 22nd.

I also tried it with the top of trunk boost as of today this minute:

> /usr/intel/pkgs/icc/9.0.030/bin/icc -I ~/30days/boost-trunk test3.cpp
> /usr/intel/pkgs/icc/10.0.026/bin/icc -I ~/30days/boost-trunk test3.cpp

Again, no compiler errors.

I can't tell you why you get errors, while I don't. It could be that
I'm being dense and didn't understand your problem. I'm not using
Fedora, but I don't see why that would matter. Happy hunting.

(I am not in the compiler group at Intel, I work in a different group.)

Boost list run by bdawes at, gregod at, cpdaniel at, john at