Boost logo

Boost :

From: John Maddock (john_at_[hidden])
Date: 2008-07-29 07:58:41

Bruno Lalande wrote:
> Hi,
>> It's also tempting to add a "member_object" trait at the same time
>> that transforms:
>> int (foo::*) --> foo
>> int (foo::*)(double) --> foo
> Good idea, just a little naming consideration: member_to_object or
> object_from_member would sound more explicit to me...

Ah, yes the old naming problem ;-)

Don't forget the trait will likely always be used with the ::type suffix, so


doesn't look so bad to me, but anyone else have preferences for these or
other names?

Thanks, John.

Boost list run by bdawes at, gregod at, cpdaniel at, john at