Boost logo

Boost :

From: Niels Dekker - mail address until 2008-12-31 (nd_mail_address_valid_until_2008-12-31_at_[hidden])
Date: 2008-07-31 16:23:19

>> So do you think it's safe to remove the swap_adl_barrier namespace from
>> now?

Steven Watanabe wrote:
> Yes. As it doesn't do any good, it's better to remove it to avoid
> confusing people.

Just committed :-)

Should we refer to your technique (making sure that std::swap is more
specialized than boost::swap) as an "ADL barrier" as well? Or is a
different term more appropriate? Is it a known C++ "idiom"?

I'm asking because the term "barrier namespace" still needs to be
replaced by something else, at two places within the documentation:

Kind regards, Niels

Boost list run by bdawes at, gregod at, cpdaniel at, john at