Boost logo

Boost :

Subject: Re: [boost] Formal Review Request: Boost.String.Convert
From: Scott McMurray ([hidden])
Date: 2009-02-17 15:11:03

On Tue, Feb 17, 2009 at 14:55, Stewart, Robert <Robert.Stewart_at_[hidden]> wrote:
> The arguments, whether function or template, would specify the conversion to apply. For example, to_string<int>(s) could also be written as convert<int>(s). (Both can be rearranged to take two arguments and return a bool, for example, so the point is merely to eliminate directionality and "string" from the name.)

Why is removing directionality from the name a good idea?

It seems like implicit_cast, for example, exists precisely for the
readability gain of being unidirectional instead of using the
bidirectional static_cast.

Boost list run by bdawes at, gregod at, cpdaniel at, john at