Subject: Re: [boost] Formal Review Request: Boost.String.Convert
From: Scott McMurray (me22.ca+boost_at_[hidden])
Date: 2009-02-17 15:47:02
On Tue, Feb 17, 2009 at 15:32, Stewart, Robert <Robert.Stewart_at_[hidden]> wrote:
> On Tuesday, February 17, 2009 3:11 PM
> Scott McMurray wrote:
>> Why is removing directionality from the name a good idea?
> With just one name to remember -- the arguments can supply the rest -- the interface is simpler.
To continue my analogy, it would have been possible to only have
static_cast and dynamic_cast, with the arguments supplying the rest,
but it's better to make it clearer which can of conversion is being
"Convert" seems like it could make a very nice namespace/library name
because of the same generality that makes me dislike it as a function
name: convert::to_string<wstring>, convert::to_integral<int,
rounding::down>, convert::transcode_string<wstring, native_mbcs>, ...
Although convert might allow mix-fix relatively nicely: