Boost logo

Boost :

Subject: Re: [boost] Formal Review: Boost.RangeEx
From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2009-02-25 16:11:28

Vicente Botet skrev:

>> Dear Giovanni,
>> On Wed, Feb 25, 2009 at 5:13 PM, Giovanni Piero Deretta <gpderetta_at_[hidden]
>>> wrote:

>> Yes, I think I might have over-emphasised the difference. Would you prefer
>> the function overload to be in the boost::adaptors namespace, the boost
>> namespace or something else?
>>>> I had considered
>>>> creating a range adaptor to be highly different to applying an algorithm,
>>>> perhaps I over-emphasised this distinction when making the decision.
>>> FWIW, I have code like this:
>>> total = ( r | filter(_r, f) | map(_r, m) | accumulate(_r, zero, a) );
>>> i.e. I don't have a strong distinction between adaptor and algorithms.
>> Yes, I'm sold!
> I agree, the introduction of the parameter (_r) makes the library homogeneus. An adaptor is a functor with a placeholder for the input parameter.

I my examples I removed the _r from the syntax. I don't see the point in
having them, if the code can work without them. Are they really needed?


Boost list run by bdawes at, gregod at, cpdaniel at, john at