Subject: Re: [boost] Formal Review: Boost.RangeEx
From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2009-02-25 16:09:46
Giovanni Piero Deretta skrev:
> On Wed, Feb 25, 2009 at 7:39 PM, Thorsten Ottosen
> Again, I think that the mutating and not mutating algorithm should
> have different names.
And how is that different from the way adaptors have been given
different names from algorithm in the library's current implementation?
> IIRC there is no requirement for the range to be sorted: unique will
> just remove all but one elements on a run of equivalent elements. But
> I agree that's not how it is often used.
> Anyways, probably that's more of a case for encapsulating the
> sort/unique/erase sequence in a single algorithm.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk