Boost logo

Boost :

Subject: Re: [boost] Formal Review: Boost.RangeEx
From: Giovanni Piero Deretta (gpderetta_at_[hidden])
Date: 2009-02-25 16:28:25

On Wed, Feb 25, 2009 at 10:07 PM, Thorsten Ottosen
<thorsten.ottosen_at_[hidden]> wrote:
> vicente.botet skrev:
>> As unique exist already, what about unique_view. With the _view suffix we
>> state clearly that the evaluation is lazy.
> Just to make sure there is no confusion on this point, then the orignal _ed
> suffix was supposed to mean "lazy". That doesn't mean it is perfect naming
> scheme, of course.

No confusion, at least from my part. I think the -ed sufix does convey
the lazyness of the algorithm. I'm just against it for purely
aesthetic reasons. I could live with it (and in fact i prefer it to
the _view variant, at least is shorter and easier to type).


Boost list run by bdawes at, gregod at, cpdaniel at, john at