Subject: Re: [boost] Formal Review: Boost.RangeEx
From: Joel de Guzman (joel_at_[hidden])
Date: 2009-02-28 10:35:37
Kai Schroeder wrote:
> Hi Neil,
> On Thu, Feb 26, 2009 at 1:41 PM, Neil Groves <neil_at_[hidden]>wrote:
>> Dear Mathias,
>> On Thu, Feb 26, 2009 at 12:33 PM, Mathias Gaunard <
>> mathias.gaunard_at_[hidden]> wrote:
>>> Neil Groves wrote:
>>> So is everyone happy if I:
>>>> 1. Change the 'ed' adaptors to _view
>>> I wouldn't be too happy about it.
>>> The lazy adaptors being preferred over the eager in-place algorithms, the
>>> name of the adaptors should be as short as possible, especially since
>>> chaining of adaptors can lead to fairly long expressions.
>> I'm not going to do this change. It appears that more people are happy with
>> the current 'ed' ending than a '_view' ending. I don't have a strong
>> at all on this issue, but it's clear the majority prefer 'ed'. It's great
>> have reviewers so I can stop guessing.
> As nobody has mentioned it yet, I would like to point out that boost:gil
> already uses the _view ending. Quoting from the documentation:
> An image view is a generalization of STL's range concept to multiple
> dimensions. Similar to ranges (and iterators), image views are shallow,
> don't own the underlying data and don't propagate their constness over the
> data. For example, a constant image view cannot be resized, but may allow
> modifying the pixels.
> GIL uses names like greyscale_view, nth_channel_view, planar_rgb_view. Using
> 'ed' style naming one could use names like greyscale_converted,
> nth_channel_selected. I am not sure what naming scheme is better but some
> consistency within boost would be nice.
Let me add that both Fusion and MPL also use _view to name views.
It's so obvious and natural. OTOH, 'ed'? Duh! ;-)
For the sake of consistency with Boost libraries, please name it
-- Joel de Guzman http://www.boostpro.com http://spirit.sf.net
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk