Subject: [boost] BOOST_ASSERT_IF() [again]
From: Thorsten Ottosen (thorsten.ottosen_at_[hidden])
Date: 2009-05-05 17:27:21
Does anyone oppose that I add this macro to supplement BOOST_ASSERT()?
It's defined simply as
#define BOOST_ASSERT_IF(IF,X) BOOST_ASSERT( (!(IF)) || (X) )
I think it renders assertions somewhat easier to read.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk