Subject: Re: [boost] BOOST_ASSERT_IF() [again]
From: Richard Holden (aciddeath_at_[hidden])
Date: 2009-05-05 20:11:16
Thorsten Ottosen wrote:
> Hi Everyone,
> Does anyone oppose that I add this macro to supplement BOOST_ASSERT()?
> It's defined simply as
> #define BOOST_ASSERT_IF(IF,X) BOOST_ASSERT( (!(IF)) || (X) )
> I think it renders assertions somewhat easier to read.
> Unsubscribe & other changes:
Could you provide an usage example please, I understand the macro but I
don't understand the usage pattern.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk