Boost logo

Boost :

Subject: Re: [boost] [range][rangex] Joining two unrelated ranges?
From: Mathias Gaunard (mathias.gaunard_at_[hidden])
Date: 2009-06-23 11:35:39

Joel de Guzman wrote:

> In Fusion (and also in MPL), it's called joint_view:
> and there's the fusion::join algo:
> If anyone writes such a thing (I'm surprised RangeEx does not have it),
> please follow MPL/Fusion's lead.

I'm not sure an agreement was reached during review as to what naming to
use for "lazy" range operations.

According to the initial naming convention RangeEx used, it would be
called "joined" and not "join_view".

Boost list run by bdawes at, gregod at, cpdaniel at, john at