Boost logo

Boost :

Subject: Re: [boost] [range][rangex] Joining two unrelated ranges?
From: Joel de Guzman (joel_at_[hidden])
Date: 2009-06-23 20:52:49

Mathias Gaunard wrote:
> Joel de Guzman wrote:
>> In Fusion (and also in MPL), it's called joint_view:
>> and there's the fusion::join algo:
>> If anyone writes such a thing (I'm surprised RangeEx does not have it),
>> please follow MPL/Fusion's lead.
> I'm not sure an agreement was reached during review as to what naming to
> use for "lazy" range operations.
> According to the initial naming convention RangeEx used, it would be
> called "joined" and not "join_view".

Sigh, yeah, I recall the review. I'll just hope the people involved
will value precedence and consistency.


Joel de Guzman

Boost list run by bdawes at, gregod at, cpdaniel at, john at