Boost logo

Boost :

Subject: Re: [boost] [convert] Now with Boost.Parameter interface.
From: Scott McMurray ([hidden])
Date: 2009-07-02 11:45:12

2009/7/2 Stewart, Robert <Robert.Stewart_at_[hidden]>:
> Why not with the syntax Dave has been suggesting:
>   converter<int>(locale_ = loc, throw_ = true).from(str, 0);

To me, that's the nicest one yet proposed.

And it'd be quite reasonable, instead of statics, to just use
convert<int>().from(str, 0), since that's already common from function

And actually, why not spell from() as operator(), so it can be a
proper function object?

transform( istream_iterator<string>(cin), istream_iterator<string>(),
back_inserter(v), convert<int>(locale_ = loc, base_ = 16, throw_ =
false, default_ = 0));

Boost list run by bdawes at, gregod at, cpdaniel at, john at