Subject: Re: [boost] [move][container] Review Request (new versions of Boost.Move and Boost.Container in sandbox and vault)
From: Christian Schladetsch (christian.schladetsch_at_[hidden])
Date: 2009-08-12 18:55:48
Looks good; personally I've been waiting for this so I'm extremely pleased
to see the great work Ion has done here!
A few small suggestions:
Is BOOST_MOVABLE_BUT_NOT_COPYABLE better called
BOOST_MOVABLE_AND_NOT_COPYABLE? Or even BOOST_MOVABLE_NOT_COPYABLE or
Specifically, why the exceptional 'but' rather than an inclusive 'and'; or
just elide the conjunction altogether?
Should the limit BOOST_CONTAINERS_MAX_CONSTRUCTOR_PARAMETERS use
BOOST_CONTAINER_... (ie, drop the pluralising 'S')? Similarly for other
pre-processor symbols; some use BOOST_CONTAINERS_ and others use
I note that there is a containers_detail namespace; since this this not part
of the public interface there is no case for renaming this to
container_detail other than internal consistency.
The stable_vector is nice (same as chain<T>), just some of the pre-processor
symbols don't have BOOST_ prefixes, and CONTAINERS_ vs. CONTAINER_ comes up
again. This is niggly, sure.
I'm pleased that Ion has taken the time to do this, and do it well. Now I
can finish monotonic with both stateful and stateless allocators.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk