Boost logo

Boost :

Subject: Re: [boost] [UUID] uuid.hpp Objective C++ conflict.
From: Mostafa (mostafa_working_away_at_[hidden])
Date: 2009-08-18 08:08:10

Scott McMurray wrote:
> 2009/8/17 M M <mostafa_working_away_at_[hidden]>:
>> 1) Given this conflict, will you still proceed with the same function name? (As an fyi, all other boost libraries I've incorporated into the iphone fortunately don't have this problem.)
> The name was chosen as that's what it's called in S4.1.7 of the UUID
> RFC:
> Do you have a suggestion for a new one?

1.0) Why not make a static class variable named NIL, since nil() returns
the same value all the time?

2) (I know this is off topic and I admit that I haven't researched the
mailinglists for this one) If it's still going to remain a function,
shouldn't it be static?

Boost list run by bdawes at, gregod at, cpdaniel at, john at