Boost logo

Boost :

Subject: Re: [boost] [UUID] uuid.hpp Objective C++ conflict.
From: Mostafa (mostafa_working_away_at_[hidden])
Date: 2009-08-18 12:28:51

Mostafa wrote:
> 1.0) Why not make a static class variable named NIL, since nil() returns
> the same value all the time?
> 2) (I know this is off topic and I admit that I haven't researched the
> mailinglists for this one) If it's still going to remain a function,
> shouldn't it be static?

Oops: I thought "uuid nil()" was a method of class uuid. So the class I
was talking about in 1) and 2) refer to class uuid.

As for 2), now I'm wondering why this particular function is a namespace
function and not a method (static) of class uuid? (I'll scrounge the
mailing lists for an answer in the mean time).

Boost list run by bdawes at, gregod at, cpdaniel at, john at