Boost logo

Boost :

Subject: Re: [boost] [UUID] uuid.hpp Objective C++ conflict.
From: Scott McMurray ([hidden])
Date: 2009-08-20 13:53:08

2009/8/18 Mostafa <mostafa_working_away_at_[hidden]>:
> 1.0) Why not make a static class variable named NIL, since nil() returns
> the same value all the time?

Actually, is there a define for Objective C like __cplusplus? Since
the value-initializer of a POD uuid gives a nil UUID, the function is
just in case someone wishes added clarity, and could be #ifndef'ed out

> As for 2), now I'm wondering why this particular function is a namespace
> function and not a method (static) of class uuid?  (I'll scrounge the
> mailing lists for an answer in the mean time).

Part of the point of the alt v13 was to turn the uuid class itself
into a completely minimal dumb value type. All UUID generation (be it
random, time-based, hash-based, known values, ...) was moved outside.
Part of the advantage of this is in making uuid.hpp as limited as
possible, avoiding the need to pull SHA1 hashing or Mercenne Twisters,
for instance, into an interface header just because it has a uuid
parameter somewhere.

Boost list run by bdawes at, gregod at, cpdaniel at, john at