|
Boost : |
Subject: Re: [boost] Review Request: Boost.Itl; The Interval Template Library
From: Joachim Faulhaber (afojgo_at_[hidden])
Date: 2009-09-23 06:48:50
2009/9/21 Simonson, Lucanus J <lucanus.j.simonson_at_[hidden]>:
> Joachim Faulhaber wrote:
>>>> the Interval Template Library is now in a state
>>>> where I think it does conform the requirements
>>>> and guidelines for boost libraries fairly well.
>>>
>>>(Markus Werle)
>>> Actually I am very unlucky with the name "itl".
>
>
> I'd suggest naming it either Interval Set--boost::interval_set or Interval Set Library--boost::isl.
>
after pondering for a while I tend to prefer this name
Compact Associative Containers
boost::compass
I think this name is appropriate with respect to scope and level of abstraction.
* The lib provides containers
* It implements sets and maps which are known as associative containers.
* It implements them exploiting a compact representation (intervals)
* The central requirements of the compact representations is that
key elements of the containers are LessThan *comp*arable. So the
acronym compass can also express that the domain_type of the
*ass*ociative containers has to be *comp*arable.
* The name omits 'interval' which prevents one of the most frequent
misunderstandings that the library's interval_sets are sets of intervals or
that interval_maps map intervals to values. Instead they are
associative containers of elements in a compact implementation
*using* intervals.
Thoughts?
-- Joachim
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk