|
Boost : |
Subject: Re: [boost] coding conventions
From: Mathias Gaunard (mathias.gaunard_at_[hidden])
Date: 2010-01-03 05:21:44
Michael a écrit :
> hi all,
>
> here's a first patch:
>
> it was generated using the command 'svn diff > ../boost.diff"
>
> questions on the formatting of new code (conforming standards used at
> gdb-patches_at_[hidden]):
>
> 1) can lines exceed the 80 character limit?
> 2) should standard indentation be taken as 2 or 4 white spaces?
>
> the attachment can be applied as such.
>
- if (size > 0)
- s << v () (0);
+ if (size > 0) s << v () (0);
Not an improvement in readability to me, on the contrary.
- for (size_type i = 1; i < size; ++ i)
- s << ',' << v () (i);
- s << ')';
+ for (size_type i = 1; i < size; ++ i)
+ {
+ s << ',' << v () (i);
+ s << ')';
+ }
+
You changed the code here...
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk