Boost logo

Boost :

Subject: Re: [boost] Message Hashing Interface (SHA-1/256/384/512, MD4/5)
From: Nevin Liber (nevin_at_[hidden])
Date: 2010-04-10 11:49:55

On 10 April 2010 10:45, Daniel Trebbien <dtrebbien_at_[hidden]> wrote:
> +1 and one, minor suggestion: why not name `end_message` simply `end`?
> I am of the opinion that naming should follow the language's standard
> library conventions closely. And, as the STL uses short, concise
> member function names, it is best to mimic this.

If you intend on shortening the name of this function (and I don't
feel strongly about it one way or the other), I'd say pick a different
word, such as finish(). end() has too many connotations connected
with the STL.

 Nevin Liber  <mailto:nevin_at_[hidden]>  (847) 691-1404

Boost list run by bdawes at, gregod at, cpdaniel at, john at