Subject: Re: [boost] 1.43.0 range_ex
From: Mathias Gaunard (mathias.gaunard_at_[hidden])
Date: 2010-05-06 10:27:53
Le 06/05/2010 08:13, Neil Groves a écrit :
> The change was in response to review feedback. There were a large number of
> people that strongly believe that make_XXX_range was too long and the
> distinction was unnecessary. I pushed back quite hard with the same
> rationale as you just provided, but actually I think the feedback was good.
> I have been using the new version with the shorter name and it the source
> code reads better. I typically do rng | adaptors::reversed. The
> boost::adaptors::reverse(rng) seems pretty clear too.
Out of curiosity, couldn't it have been the same name for both?
rng | boost::adaptors::reversed
having the same behaviour.
Or would that have runtime overhead? Didn't really try to see what kind
of code would be needed.
> I hope this change doesn't upset anyone too much. I have tried hard to
> respond constructively to the naming arguments.
I myself am quite happy with short names, because I like terse code.