Subject: Re: [boost] [xint] Fourth release, requesting preliminary review again
From: John Bytheway (jbytheway+boost_at_[hidden])
Date: 2010-06-02 15:44:32
On 02/06/10 20:24, Chad Nelson wrote:
> On 06/02/2010 12:02 PM, Marius Stoica wrote:
>> The documentation got a bit harder to read since it redundantly
>> repeats the template arguments. Can something be done about that?
> I've thought the same thing, and I don't yet know what to do about it.
> The only way I can think to fix it is to rewrite all of the functions as
> non-templates, purely for documentation purposes.
Could you use a macro which is defined differently int the compilation
and documentation-generation passes?
>> I consider using size_t for size in bits a little
>> confusing/annoying. Maby you should typedef size_t bits_t; ?
> I'm not sure I understand the complaint. size_t is the standard type for
> sizes. Wouldn't introducing a new type, which is just an alias for an
> existing and well-known type, be more confusing to people?
There is precedent in std::bitset for using size_t to count bits; I
think it's fine.