Subject: Re: [boost] [boost::endian] Summary of discussion #1
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-06-04 10:23:04
> Rob Stewart wrote:
> > Vicente Botet wrote:
> >> Rob Stewart wrote:
> >> > Scott McMurray wrote:
> >> >> Rob Stewart wrote:
> >> >> >
> >> >> > "endian_pack" doesn't suggest the class' actual purpose
> >> >>
> >> >> I'd guess that pack was chosen thinking of the verb,
> >> >> like the perl function pack:
> >> >> <http://perldoc.perl.org/functions/pack.html>.
> >> >
> >> > Perhaps, but while function names are rightly verbs, type
> >> > names should be nouns.
> >> So the noum shoud be?
> > I suggested some in another reply.
> Please could you repeate it here, I don't remember which one
> of your suggestion used the noum for pack.
I suggested compressed_endian_integer. See my reply in that other part of the thread for subsequent discussion of such names.
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk