Subject: Re: [boost] [gsoc] Pointer Plus Bits Behavior and Interface
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-07-16 07:27:14
Andrew Sutton wrote:
> The class is called "pointer... plus bits". If the abstraction
> isn't at least a little bit pointer-like, then the name of the
> data type is duplicitous at best. I think that some of the
> suggestions treat lightly the attachment that programmers have
> to the meanings of names.
Rereading the above, I realized that I wasn't putting as much emphasis on "plus" as you. I was reading the name much more like "pointer_and_bits," so the pointer focus was less strong for me. I now see your problem with the current name. Just changing "plus" to "and" would probably alleviate your concern, but reversing the order, as I suggested elsewhere, may be even more satisfactory.
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk