Subject: Re: [boost] [gsoc] Pointer Plus Bits Behavior and Interface
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-07-16 07:22:59
Scott McMurray wrote:
> On 15 July 2010 21:00, Andrew Sutton
> <andrew.n.sutton_at_[hidden]> wrote:
> > I would think that the point of creating this particular data type
> > (pointer_plus_bits) was to emphasize the pointer aspect and
> > less so the "pair".
> I think that's a point-of-view difference. When I heard of it, I
> immediately thought of "compressed pair with non-empty things".
Emphasizing the tuple aspect may be useful. The generalized bitfield_tuple is a reasonable building block, but if one of the elements is a pointer, it seems a name with "pointer" in it would be better. For that, just reversing the terms might do well. I also suggested, elsewhere, that "bits" be replaced with "data," "values," or something like that. Therefore, consider these combinations:
"data" is shorter, so I favor it over "values." "data_and_pointer" lends itself to an acronym, "DAP," which might prove useful.
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.