Subject: Re: [boost] New name of bjam.exe
From: Brian Ravnsgaard Riis (brian_at_[hidden])
Date: 2010-07-20 06:19:24
-----BEGIN PGP SIGNED MESSAGE-----
On 20-07-2010 12:05, Artyom wrote:
> "build" is not good as it some kind of "namespace pollution",
> and is very problematic for systems with single "bin" path - as most Unix like
> So you need something unique starting with boost prefix as namespace.
> For example all mysql utilities start with mysql prefix thus I think boost build
> should be
> something like
> boost_build or boostbld, not really matter, the point is clear.
It is indeed, but I don't actually think I agree... except that "build"
is too generic. This command will be typed into a console a hundred
times a day in some cases, so it should be rather short. "bjam" was good
in this regard, but not really accurate any longer, as Volodya states.
>> IMHO, "build" is a very generic name.
>> > Maybe something like "bbuild" (where the first "b" stands for Boost)
>> > might just help me to remember this is a boost related tool
>> > Cheers,
>> > -- Marco
>> > _______________________________________________
>> > Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
> Agree. It's too much generic.
> Some additional suggestions:
My preference would be for "bmake" although "mkbb" is also ok. My first
thought there was "make boost build?" though, and that's not what it
does. But either is both distinctive and easy to type, so...
+1 for bmake (or mkbb).
- -1 for boost_build!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
-----END PGP SIGNATURE-----
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk