Subject: Re: [boost] New name of bjam.exe
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2010-07-20 06:58:53
Vladimir Prus wrote:
> Stewart, Robert wrote:
> > My suggestion: build_boost. While "boost" isn't a prefix
> > in that name, it reads very nicely in English. Furthermore,
> > if "Boost.Build" remains as a library/project name, then the
> > reversal in "build_boost" is useful to avoid conflation of
> > the two names. That is, the binary isn't the
> > library/project and vice versa, so distinct but related
> > names are useful.
> But, "build_boost" sounds like a command that, well, "builds"
> something called "boost", no?
Isn't that the point? It is used to build Boost libraries individually and collectively, right?
> And Boost.Build has significant use to build things that are
> not "Boost C++ Libraries".
Are they not related?
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk