Subject: Re: [boost] New name of bjam.exe
From: Vladimir Prus (vladimir_at_[hidden])
Date: 2010-07-20 07:38:16
Stewart, Robert wrote:
> Vladimir Prus wrote:
>> Stewart, Robert wrote:
>> > My suggestion: build_boost. While "boost" isn't a prefix
>> > in that name, it reads very nicely in English. Furthermore,
>> > if "Boost.Build" remains as a library/project name, then the
>> > reversal in "build_boost" is useful to avoid conflation of
>> > the two names. That is, the binary isn't the
>> > library/project and vice versa, so distinct but related
>> > names are useful.
>> But, "build_boost" sounds like a command that, well, "builds"
>> something called "boost", no?
> Isn't that the point? It is used to build Boost libraries individually and collectively, right?
Not really. It's used to build C++ projects, of which "Boost C++ Libraries" is one example.
If we cared only about building one project, then the question of naming would not
matter much -- 'build' would be just fine.