Boost logo

Boost :

Subject: Re: [boost] accurate sum accumulator (kahan)
From: Matthias Troyer (troyer_at_[hidden])
Date: 2010-07-26 11:53:42

On 26 Jul 2010, at 09:51, David Abrahams wrote:

> At Mon, 26 Jul 2010 16:20:16 +0100,
> Paul A. Bristow wrote:
>>> -----Original Message-----
>>> From: boost-bounces_at_[hidden] [mailto:boost-bounces_at_[hidden]] On Behalf Of David Abrahams
>>> Sent: Monday, July 26, 2010 3:10 PM
>>> To: boost_at_[hidden]
>>> Subject: Re: [boost] accurate sum accumulator (kahan)
>>> At Mon, 26 Jul 2010 14:59:29 +0100,
>>> Paul A. Bristow wrote:
>>>> PS As for naming, I'd vote for sum and accurate_sum (to keep backward compatibility).
>>> It's possible I'm completely off the mark here, but I think maybe we
>>> want sum and quick_sum.
>> This would be ideal - but doesn't accumulator already use 'sum' so it would change behaviour of existing programs?
> Technically, of course it would, but aren't they getting the wrong answer currently?

I would still call it sum. We have accurate versus quick versions of variance and other accumulators that can be specified like "variance(accurate)" in the feature list (namespaces missing ... it has been a while since I used it last). I would just propose to add this sum as "sum(accurate)"


Boost list run by bdawes at, gregod at, cpdaniel at, john at