Boost logo

Boost :

Subject: Re: [boost] [fusion] [intro] ADAPT_STRUCT extensions
From: Lars Viklund (zao_at_[hidden])
Date: 2010-08-13 06:46:41

On Fri, Aug 13, 2010 at 12:10:23PM +0200, Stefan Strasser wrote:
> Zitat von Joel de Guzman <joel_at_[hidden]>:
>> C'mon guys! We're venturing into the name-game land!
>> If that's the game, then we should shout out why C++ confusingly
>> has "struct" and "class" anyway which both have very little nuance.
>> I don't want to go there. Sorry. This is not going to be another
>> bike-shed issue.
> that's a lot of confusion for a still undocumented bike-shed.

For what it's worth, the first time I saw the macro mentioned on-list, I
wondered why you needed a special macro for classes when you had a
perfectly fine one for structs.

Due to the fine distinction between struct/class, naming it _CLASS_
would be doing everyone a disservice as it gives it connotations it
shouldn't have.

As for what it should be named, I won't suggest anything, as long as
it's less ambigious.

Lars Viklund | zao_at_[hidden]

Boost list run by bdawes at, gregod at, cpdaniel at, john at