Boost logo

Boost :

Subject: Re: [boost] [gsoc] Boost.Process done
From: Boris Schaeling (boris_at_[hidden])
Date: 2010-09-15 17:50:11


Here is the next (minor) update of the library (ZIP file updated at
<http://www.highscore.de/boost/gsoc2010/process.zip>; changes in
Subversion at <http://svn.boost.org/svn/boost/sandbox/SOC/2010/process/>).

What has been changed?

* The constructor of boost::process::handle supports an optional parameter
to specify whether a handle should be automatically closed (by default the
handle is closed). boost::process::behavior::inherit passes "dont_close"
to the constructor to avoid that a handle inherited by a child process is
closed by the parent process (as the handle is inherited it is a handle in
use by the parent process and must not be closed). The function
boost::process::create_child() does not explicitly close handles anymore
but simply lets them go out of scope.

* The stream behaviors don't return a std::pair<handle, handle> anymore.
There is now a new struct called boost::process::stream_ends which has two
member variables child and parent. Now there is no need anymore to
remember whether first or second was the child's end.

I'd appreciate if you could comment on the changes. Especially have a look
at:

* the enumeration close_type in boost::process::handle (see
<http://svn.boost.org/svn/boost/sandbox/SOC/2010/process/boost/process/handle.hpp>).
Is there a better name for the enumeration? Are there better names for the
values in the enumeration? I don't like "do_close" but then the name
"close" is already used at too many other places.

As this is a minor update there will be some more changes soon (hopefully
this weekend).

Boris


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk