Boost logo

Boost :

Subject: Re: [boost] [constrained_value] Constrained Value review results
From: Christian Holmquist (c.holmquist_at_[hidden])
Date: 2010-10-06 08:46:19

On 5 October 2010 20:43, Robert Kawulak <robert.kawulak_at_[hidden]> wrote:

> Hello All,
> As Gordon Woodhull has suggested, it'd be nice to try finding a better name
> for bounded_int:
> > The unique characteristic of this class is not that it's bounded or an
> int, but that the bounds are
> > specified at compile time.
I think bounded_int or bounded_integral seems just fine. The class' compile
time parameters and runtime parameters I assume the user can find in the
documentation. From the header synopsis you gave in previous post it was
already quite clear the interface.
I can't imagine you'd later get a name collision with another
bounded_integral which has runtime bounds (one doesn't need to restrict
oneself to integers if those values specified at runtime).

Just my 2 pesos,

Boost list run by bdawes at, gregod at, cpdaniel at, john at