Boost logo

Boost :

Subject: Re: [boost] [constrained_value] Constrained Value review results
From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2010-10-06 09:20:42

Den 06-10-2010 14:46, Christian Holmquist skrev:
> On 5 October 2010 20:43, Robert Kawulak<robert.kawulak_at_[hidden]> wrote:
>> Hello All,
>> As Gordon Woodhull has suggested, it'd be nice to try finding a better name
>> for bounded_int:
>>> The unique characteristic of this class is not that it's bounded or an
>> int, but that the bounds are
>>> specified at compile time.
> I think bounded_int or bounded_integral seems just fine. The class' compile
> time parameters and runtime parameters I assume the user can find in the
> documentation. From the header synopsis you gave in previous post it was
> already quite clear the interface.

bounded_int and bounded_float is fine with me too. Since the library is
called constrained_value, contrained_int and constrained_float would be
fine too.


Boost list run by bdawes at, gregod at, cpdaniel at, john at