Subject: Re: [boost] [constrained_value] Constrained Value review results
From: Thorsten Ottosen (nesotto_at_[hidden])
Date: 2010-10-08 08:37:18
Den 07-10-2010 18:27, vicente.botet skrev:
> ----- Original Message -----
> From: "Robert Kawulak"<robert.kawulak_at_[hidden]>
> Sent: Thursday, October 07, 2010 2:45 AM
> Subject: Re: [boost] [constrained_value] Constrained Value review results
>>> From: Paul A. Bristow
>>> I also like the word 'static' - it implies 'fixed at compile time' to me,
>>> but I agree static has other possible implications.
>> How about "statically_bounded"?
> +1. But I prefer static_bounded that follows the existing static_log2, static_gcd, ... in Boost.Math.
I'm not awfully happy with the names suggested so far. At the outset
is a good name. Now, since the bounds, /not the actualy bounding/, can
be configured either at compiler-time or run-time, we need some way of
What about namespaces?