Boost logo

Boost :

Subject: Re: [boost] [Review] Formal Review of Proposed Boost.RatioLibrary IS UNDERWAY
From: John Maddock (boost.regex_at_[hidden])
Date: 2010-10-12 03:38:08

>> - BOOST_INTMAX_C is the only macro that's defined in ratio.hpp but not
>> staring with BOOST_RATIO_. As the name suggests, it'll be better 1) if
>> placed in boost/cstdint.hpp, or 2)be named as BOOST_RATIO_INTMAX_C
>> indicating that it's used for boost.ratio only, I personally prefer
>> option 1).
> I'll see if we can add it to cstdint.hpp. Waiting for that I will rename
> the
> macro.

The C99 macros INTMAX_C and UINTMAX_C are already present in

HTH, John.

Boost list run by bdawes at, gregod at, cpdaniel at, john at