Subject: Re: [boost] review request: addition to type_traits library ofhas_operator_xxx
From: Petr PilaÅ (email_at_[hidden])
Date: 2010-11-20 11:02:35
> > I forgot about this when I made my suggestion. I myself would not find
> > boost::type_traits::operators to be too onerous, since after all one
> > could alias the namespace as one likes, but I am a much stronger
> > proponent of clarity in reading code than how much I have to type and
> > many others seem to find important how many letters they have to type to
> > use something in their code.
> So how do we decide for one or the other solution. What would be the
> way to decide?
> As far as I am concerned, I have no strong opinion. The namespace
> solution looks clearer but I like short typing too...
> Do we need to organize sort of a vote?
The namespace solution can, if you alias the namespace properly, lead to
shorter writing... that is the nice thing, the namespace approach should
satisfy both groups (those who like shorter names and those who like longer
but perhaps more descriptive names). It's a win win, in my opinion.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk