Subject: Re: [boost] review request: addition to type_traits library ofhas_operator_xxx
From: Frédéric Bron (frederic.bron_at_[hidden])
Date: 2010-11-20 10:48:37
>> * I'm not that keen on the operators:: subnamespace, to me that
>> namespace is reserved for the operators library
>> http://www.boost.org/doc/libs/1_45_0/libs/utility/operators.htm it would
>> have to be boost::type_traits::operators I guess which is rather less
>> cute :-(
> I forgot about this when I made my suggestion. I myself would not find
> boost::type_traits::operators to be too onerous, since after all one could
> alias the namespace as one likes, but I am a much stronger proponent of
> clarity in reading code than how much I have to type and many others seem to
> find important how many letters they have to type to use something in their
So how do we decide for one or the other solution. What would be the
way to decide?
As far as I am concerned, I have no strong opinion. The namespace
solution looks clearer but I like short typing too...
Do we need to organize sort of a vote?
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk