Subject: Re: [boost] namespace boost?
From: Dave Abrahams (dave_at_[hidden])
Date: 2011-01-15 23:24:27
At Sat, 15 Jan 2011 17:12:37 -0500,
Kim Barrett wrote:
> On Jan 15, 2011, at 4:46 PM, Dave Abrahams wrote:
> >>> +1, although I think the name should be boost::ratio rather than
> >> boost::ratios
> > If it has a type called "ratio" in it, "ratios" might be a better
> > choice for the namespace. That, at least, is how tuple did it. I
> > can't find a good rationale for that choice now, but once upon a time
> > it used to be our recommended practice.
> "For those who are really interested in namespaces"
Interesting. I wonder if those errors they encountered with using are
conforming behavior and/or obsolete issues due to compiler fixes.
-- Dave Abrahams BoostPro Computing http://www.boostpro.com
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk