Subject: Re: [boost] namespace boost?
From: Robert Kawulak (robert.kawulak_at_[hidden])
Date: 2011-01-18 16:29:06
> From: Barend Gehrels
> The library name is normally (but not always) singular, e.g.
> Boost.Tuple, which is IMO more logical than Boost.Tuples. The folder
> name equals the library name. The library often contains a class named
> as the library, e.g. tuple, and the namespace therefore or for other
> reasons is something different, here tuples, so this requirement is
> difficult to meet.
Even I am not convinced to the idea myself, but here it is: in cases like Boost.Tuple call the folder 'tuple_lib' and the namespace
'boost::tuple_lib'. This fixes the problem with ambiguous names and looks not worse than 'tuples'.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk