Boost logo

Boost :

Subject: Re: [boost] namespace boost?
From: Barend Gehrels (barend_at_[hidden])
Date: 2011-01-19 03:18:18

>>> Even I am not convinced to the idea myself, but here it is: in cases like Boost.Tuple call the folder 'tuple_lib' and the namespace
>>> 'boost::tuple_lib'. This fixes the problem with ambiguous names and looks not worse than 'tuples'.
>> While I like the basic discussion about moving away from naming the namespace as the plural form of the class, I have always been for clarity and naming things after wthat they represent.
>> So...why not call the folder 'tuple' (as it is the name of the library), the class 'tuple' and the namespace 'tuple_nmsp'. The names would be perfectly clear, no clashes in regards to singular/plural and in addition, you clearly can identify the namespace and the class...which can be confusing from time to time with the whole tuple/tuples thing least it is for me... ;)
> Am I the only one who thinks adding the type of an identifier to the
> name is ugly? As in<identifier>_<type> (in this case `tuple_nmsp` or
> `tuple_lib`)?
> Imagine if everytime you had to call a real person instead of just
> their name you had to say "<name>, friend" or "<name>, daughter". That
> wouldn't be very nice would it?
I agree with you, those suffices are too much. Just an "s" is enough. I
personally can live with plural namespaces if they are necessary. So the
guidelines on the website (put into this thread by Joachim)

are clear, make sense, and are followed by most previous libraries. I
see no reason for change.

Regards, Barend

Boost list run by bdawes at, gregod at, cpdaniel at, john at