Subject: Re: [boost] namespace boost?
From: Dean Michael Berris (mikhailberis_at_[hidden])
Date: 2011-01-19 00:51:36
On Wed, Jan 19, 2011 at 7:06 AM, Andreas Masur <boost_at_[hidden]> wrote:
> On Jan 18, 2011, at 4:29 PM, Robert Kawulak wrote:
>>> From: Barend Gehrels
>>> The library name is normally (but not always) singular, e.g.
>>> Boost.Tuple, which is IMO more logical than Boost.Tuples. The folder
>>> name equals the library name. The library often contains a class named
>>> as the library, e.g. tuple, and the namespace therefore or for other
>>> reasons is something different, here tuples, so this requirement is
>>> difficult to meet.
>> Even I am not convinced to the idea myself, but here it is: in cases like Boost.Tuple call the folder 'tuple_lib' and the namespace
>> 'boost::tuple_lib'. This fixes the problem with ambiguous names and looks not worse than 'tuples'.
> While I like the basic discussion about moving away from naming the namespace as the plural form of the class, I have always been for clarity and naming things after wthat they represent.
> So...why not call the folder 'tuple' (as it is the name of the library), the class 'tuple' and the namespace 'tuple_nmsp'. The names would be perfectly clear, no clashes in regards to singular/plural and in addition, you clearly can identify the namespace and the class...which can be confusing from time to time with the whole tuple/tuples thing otherwise....at least it is for me... ;)
Am I the only one who thinks adding the type of an identifier to the
name is ugly? As in <identifier>_<type> (in this case `tuple_nmsp` or
Imagine if everytime you had to call a real person instead of just
their name you had to say "<name>, friend" or "<name>, daughter". That
wouldn't be very nice would it?
-- Dean Michael Berris about.me/deanberris
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk