Boost logo

Boost :

Subject: Re: [boost] namespace boost?
From: Chad Nelson (chad.thecomfychair_at_[hidden])
Date: 2011-01-19 08:43:29

On Wed, 19 Jan 2011 13:13:22 +0100
Robert Kawulak <robert.kawulak_at_[hidden]> wrote:

>> From: Dean Michael
>> Am I the only one who thinks adding the type of an identifier to the
>> name is ugly? As in <identifier>_<type> (in this case `tuple_nmsp` or
>> `tuple_lib`)?
> I think everyone likes the names without postfixes more, but there's
> the issue with name clashes. I, on the other hand, avoided the clash
> of the central class name in my library - constrained - by calling the
> library Constrained Value and the namespace constrained_value. But in
> some cases it's not easy to make up a meaningful and not ugly name.

I use the _t suffix for types, when I need a namespace of the same name
(and often when I don't too). wchar_t and the int*_t/uint*_t types have
made it a fairly accepted practice. I'm ambivalent about it, but it
*does* solve the problem.

Chad Nelson
Oak Circle Software, Inc.

Boost list run by bdawes at, gregod at, cpdaniel at, john at