Boost logo

Boost :

Subject: Re: [boost] namespace boost?
From: Robert Kawulak (robert.kawulak_at_[hidden])
Date: 2011-01-19 07:13:22

> From: Dean Michael
> Am I the only one who thinks adding the type of an identifier to the
> name is ugly? As in <identifier>_<type> (in this case `tuple_nmsp` or
> `tuple_lib`)?

I think everyone likes the names without postfixes more, but there's the issue with name clashes. I, on the other hand, avoided the
clash of the central class name in my library - constrained - by calling the library Constrained Value and the namespace
constrained_value. But in some cases it's not easy to make up a meaningful and not ugly name.

Best regards,

Boost list run by bdawes at, gregod at, cpdaniel at, john at