Subject: Re: [boost] UTF strings thread (was [string] proposal)
From: David Bergman (David.Bergman_at_[hidden])
Date: 2011-01-27 13:23:27
On Jan 27, 2011, at 1:19 PM, Chad Nelson wrote:
> On Thu, 27 Jan 2011 13:04:45 -0500
> David Bergman <David.Bergman_at_[hidden]> wrote:
>> On Jan 27, 2011, at 10:04 AM, Dean Michael Berris wrote:
>>>> That's short, but not descriptive. The "i" prefix is more
>>>> suggestive of "interface" than "immutable" to me. Why not just go
>>>> whole hog and call it "immutable_string" as Artyom suggested?
>>> The only objection really is that it's too long. :D Less characters
>>> is better.
>>> /me gets a thesaurus and looks up string :D
>> Ok, but why this focus on immutability? Is that not a quite orthogonal
>> concern to the encoding problematics discussed here (as well...)?
>> I would prefer to have this discussion be about the encoding aspect(s)
>> rather than immutability [...]
> That's my baby, which I'm still working on. Dean is working on the
> immutable string idea (which he's made a persuasive case for IMO, but
> which is really unrelated). As has been noted, the two are getting
> confused because they both came out of Artyom's original UTF-8
> proposal; I've changed the subject line on this one to (hopefully)
> split the two discussions up.
BUT, the thing is that The Other Discussion is still mentioning encoding notions and even the letters "UTF", and it should. Otherwise, that thread should be called "boost::immutable_vector" or "boost::cs_immutable_string" ;-)
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk