Subject: Re: [boost] [string] proposal
From: Stewart, Robert (Robert.Stewart_at_[hidden])
Date: 2011-01-28 09:01:49
Dean Michael Berris wrote:
> On Fri, Jan 28, 2011 at 5:58 PM, Matus Chochlik
> <chochlik_at_[hidden]> wrote:
> > On Thu, Jan 27, 2011 at 3:56 PM, Dean Michael Berris
> >> Help wanted on a better name for the immutable string. :)
> > Half-jokingly, but: what about 'chain' ? :)
> LOL -- chain I like. It's one less character than `string`. It
> involves immutability, concatenation as a means of building it, and
> it's usually segmented.
The name is unlike any other container names I've heard of, doesn't connote text, and doesn't convey useful associations like segmentation and composition.
Rob Stewart robert.stewart_at_[hidden]
Software Engineer, Core Software using std::disclaimer;
Susquehanna International Group, LLP http://www.sig.com
IMPORTANT: The information contained in this email and/or its attachments is confidential. If you are not the intended recipient, please notify the sender immediately by reply and immediately delete this message and all its attachments. Any review, use, reproduction, disclosure or dissemination of this message or any attachment by an unintended recipient is strictly prohibited. Neither this message nor any attachment is intended as or should be construed as an offer, solicitation or recommendation to buy or sell any security or other financial instrument. Neither the sender, his or her employer nor any of their respective affiliates makes any warranties as to the completeness or accuracy of any of the information contained herein or that this message or any of its attachments is free of viruses.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk